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PROJECT OVERVIEW AND MISSION 
This project was developed at Bbw Hochschule, within the Research Department, under the guidance of 
Prof. Dr.-Ing. Rene Brunotte. Our goal was to design and build a low-cost, open source bioprinter that can 
be reproduced easily by universities, research laboratories, schools, and even hobbyists at home. 



High-end bioprinters are often prohibitively expensive, limiting access to cutting-edge research and 
education. Our approach was to lower this barrier by creating a system that is: 

- A^ordable – built from commonly available components. 
- Accessible – supported with open documentation, shared files, and reproducible methods. 
- Modular – designed so parts can be swapped, upgraded, or repaired with minimal eOort. 
- E^ective – capable of reliable operation for basic bioprinting tasks while remaining simple to 

assemble and maintain. 

Most of the structural components of the printer are 3D printed, which reduces cost, simplifies 
manufacturing, and allows easy customization. By combining these printed parts with oO-the-shelf 
electronics, the design emphasizes simplicity and modularity without compromising functionality. This 
makes the printer suitable for a wide range of educational and research environments, while also 
encouraging community-driven improvements. 

The project follows an open-source philosophy, meaning all files, instructions, and resources are freely 
available. We invite others to replicate, adapt, and contribute to the development of this platform so that 
low-cost bioprinting can become more widely adopted. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

BILL OF MATERIALS 
The table below lists all the components required to build the printer, including direct links to suppliers 
where possible. These links are provided for convenience, but equivalent alternatives can be used 
depending on local availability and budget. 



Prices shown reflect the cost at the time this document was created and may vary over time or by region. 
In keeping with the open-source nature of this project, users are encouraged to adapt, substitute, or 
source parts in the way that best suits their needs. 

 

BILL OF MATERIALS 
 

NO. Component Qty. Specification Price per unit Total price Link 
       

1. Plain Bearing 14 i=8, o=12, l=20 2,2€ 30,8€ Amazon 
2. Smooth Rod 4 d=8, l=250 3,39€ 13,56€ Aliexpress 
3. Smooth Rod 4 d=8, l=200 2,79€ 11,16€ Aliexpress 
4. Smooth Rod 2 d=8, l=100 1,69€ 3,38€ Aliexpress 
5. Trapezoidal thread spindle 

with nut 
2 d=8, l=150 2,79€ 5,58€ Aliexpress 

6. Trapezoidal thread spindle 
with nut 

1 d=8, l=100 2,45€ 2,45€ Aliexpress 

7. Nema 11 stepper motor 5 shaft=5 7,19€ 35,95€ Aliexpress 
8. 608ZZ Bearing 2 i=8, o=12, t=7 0,2995€ 0,599€ Amazon 
9. MR126ZZ Bearing 1 i=6, o=12, t=4 1,518€ 1,518€ Amazon 

10. GT2 closed belt 1 l=136, t=6 4,495€ 4,495€ Amazon 
11. GT2 open belt 1 l=2m, t=6 2,55€ 2,55€ Aliexpress 
12. Audrino Mega 2560 1  3,19€ 3,19€ Aliexpress 
13. Ramps 1.6 1  1,99€ 1,99€ Aliexpress 
14. DRV8825 5  1,218€ 6,09€ Aliexpress 
15. Filament 1 1kg 12,99€ 12,99€ Amazon 
16. Screws + Nuts (estimate)    12€  

 
TOTAL COST: 148,30€ 

 

 

 

 

 

 

 

 

 

 

LIST OF 3D PRINTED PARTS 
The table below lists all components designed for 3D printing. Each part is provided in STL format for 
direct printing, as well as in STEP format for users who wish to modify or adapt the design. Several parts 

https://www.amazon.de/QUARKZMAN-Bohrung-Selbstschmierende-Graphit-Messing/dp/B0D3KXN95T/ref=sr_1_6?__mk_de_DE=%C3%85M%C3%85%C5%BD%C3%95%C3%91&crid=309AKZUQBQWEY&dib=eyJ2IjoiMSJ9.ggzRGoQAtAtRGVJ3RezTWcNt4M3NclqrWQMNjIS4pX1leH3gN-EqS6MnsNdWt6nPbNNwbjOuRiO8RXKLtA9qMh0KwwXhE2l8FMD-ccRTLBHhc4KCGyzh7DnNxYLpyGn1T-68TdXziYT-jV3bG1mAVo4k_6VAt8Swphc6PPwsb_FQ3ucnM_wxBvl3_YGjKDhKsZ7cnAqnF81MiBrASutUoDXwOn7dko4N8RtDS56V_o5krDuYuyQbP0irLrOatOvGFYQktdX2bwHthAn23zTjUyQf3OY6YEXbJfwbSscDo8k.X6sHoySBbmh6sUqdX0693xIQuooXjzQK-rYVsxYTPIw&dib_tag=se&keywords=gleitlager+8x12x20&qid=1753169570&sprefix=gleitlager+8x12x20%2Caps%2C84&sr=8-6
https://de.aliexpress.com/item/1005006293171727.html?spm=a2g0o.productlist.main.1.619cad15WFTvFv&algo_pvid=bc96142a-d473-4e4a-b478-6bd160ec0540&algo_exp_id=bc96142a-d473-4e4a-b478-6bd160ec0540-0&pdp_ext_f=%7B%22order%22%3A%223318%22%2C%22eval%22%3A%221%22%7D&pdp_npi=4%40dis%21EUR%213.58%212.15%21%21%214.09%212.46%21%40211b617b17531725307741174e7847%2112000036638889742%21sea%21DE%216077065923%21X&curPageLogUid=VSkYbiorg3DH&utparam-url=scene%3Asearch%7Cquery_from%3A
https://de.aliexpress.com/item/1005006293171727.html?spm=a2g0o.productlist.main.1.619cad15WFTvFv&algo_pvid=bc96142a-d473-4e4a-b478-6bd160ec0540&algo_exp_id=bc96142a-d473-4e4a-b478-6bd160ec0540-0&pdp_ext_f=%7B%22order%22%3A%223318%22%2C%22eval%22%3A%221%22%7D&pdp_npi=4%40dis%21EUR%213.58%212.15%21%21%214.09%212.46%21%40211b617b17531725307741174e7847%2112000036638889742%21sea%21DE%216077065923%21X&curPageLogUid=VSkYbiorg3DH&utparam-url=scene%3Asearch%7Cquery_from%3A
https://de.aliexpress.com/item/1005006293171727.html?spm=a2g0o.productlist.main.1.619cad15WFTvFv&algo_pvid=bc96142a-d473-4e4a-b478-6bd160ec0540&algo_exp_id=bc96142a-d473-4e4a-b478-6bd160ec0540-0&pdp_ext_f=%7B%22order%22%3A%223318%22%2C%22eval%22%3A%221%22%7D&pdp_npi=4%40dis%21EUR%213.58%212.15%21%21%214.09%212.46%21%40211b617b17531725307741174e7847%2112000036638889742%21sea%21DE%216077065923%21X&curPageLogUid=VSkYbiorg3DH&utparam-url=scene%3Asearch%7Cquery_from%3A
https://de.aliexpress.com/item/33019154008.html?spm=a2g0o.productlist.main.10.778113083mvM3P&aem_p4p_detail=20250722011949275305655035730000161234&algo_pvid=0e9cd24c-bdfd-428f-a046-b79c0ec48af3&algo_exp_id=0e9cd24c-bdfd-428f-a046-b79c0ec48af3-9&pdp_ext_f=%7B%22order%22%3A%225%22%2C%22eval%22%3A%221%22%7D&pdp_npi=4%40dis%21EUR%214.90%212.45%21%21%215.59%212.79%21%40211b6c1917531723889475267e9512%2112000026161382600%21sea%21DE%216077065923%21X&curPageLogUid=VnlD9brfDP3F&utparam-url=scene%3Asearch%7Cquery_from%3A&search_p4p_id=20250722011949275305655035730000161234_3
https://de.aliexpress.com/item/33019154008.html?spm=a2g0o.productlist.main.10.778113083mvM3P&aem_p4p_detail=20250722011949275305655035730000161234&algo_pvid=0e9cd24c-bdfd-428f-a046-b79c0ec48af3&algo_exp_id=0e9cd24c-bdfd-428f-a046-b79c0ec48af3-9&pdp_ext_f=%7B%22order%22%3A%225%22%2C%22eval%22%3A%221%22%7D&pdp_npi=4%40dis%21EUR%214.90%212.45%21%21%215.59%212.79%21%40211b6c1917531723889475267e9512%2112000026161382600%21sea%21DE%216077065923%21X&curPageLogUid=VnlD9brfDP3F&utparam-url=scene%3Asearch%7Cquery_from%3A&search_p4p_id=20250722011949275305655035730000161234_3
https://de.aliexpress.com/item/1005009439878709.html?spm=a2g0o.productlist.main.13.20683a850hwJC7&algo_pvid=a5bb2f12-08c6-4486-ae68-8ee7bc2785aa&algo_exp_id=a5bb2f12-08c6-4486-ae68-8ee7bc2785aa-12&pdp_ext_f=%7B%22order%22%3A%22-1%22%2C%22eval%22%3A%221%22%7D&pdp_npi=4%40dis%21EUR%2115.63%217.19%21%21%2117.84%218.20%21%40211b80c217531730004905161ee1b7%2112000049102631088%21sea%21DE%216077065923%21X&curPageLogUid=vxoTgMC1yskN&utparam-url=scene%3Asearch%7Cquery_from%3A
https://www.amazon.de/QWORK-Kugellager-Shielded-Rillenkugellager-Skateboards/dp/B09PVDDBWF/ref=sr_1_1_sspa?__mk_de_DE=%C3%85M%C3%85%C5%BD%C3%95%C3%91&crid=11KG2VA6I3RDG&dib=eyJ2IjoiMSJ9.oGDgrDxLVFJAexdz1JiuEdAZ9Yi2Mi-W7VLa0LbGQTeBcyHX0a2mjsruTSA-gmpSnkS_d5D6_y5DDswS4H4b80A9a_B_AY1btR-GCQpXPlKXf9pKU58O8IDtaH_Dvbi_OjqndOaLgnf6beYL3uU9UM4V6KNMcmsTunQ7nylQJNd6VMWWFuvIFCag-k6f6I3x4-Kkk_JrYNpgLHxooBwQV2YJcy0bnxz7RRPn6lQQ-ZK9lrF1wcd8SrN-58PcbuVMV1OAqThwp1SdMKUfpPwhHAiAoc4Ro_My2c2Nt-aEqmA.XKP3q-Gd5qNm9V4jSzicMG30DKqW3cV-8M4_yFdCltg&dib_tag=se&keywords=608zz&qid=1753170876&s=industrial&sprefix=608zz%2Cindustrial%2C108&sr=1-1-spons&sp_csd=d2lkZ2V0TmFtZT1zcF9hdGY&th=1&psc=1
https://www.amazon.de/dp/B0DS8YMP8N?ref=ppx_yo2ov_dt_b_fed_asin_title&th=1
https://www.amazon.de/dp/B07D923VHB?ref=ppx_yo2ov_dt_b_fed_asin_title&th=1
https://de.aliexpress.com/item/10000401582873.html?spm=a2g0o.productlist.main.12.4058970aIRXoBV&algo_pvid=415825a0-f3a4-45a3-ac1c-8a4254210b88&algo_exp_id=415825a0-f3a4-45a3-ac1c-8a4254210b88-11&pdp_ext_f=%7B%22order%22%3A%22574%22%2C%22eval%22%3A%221%22%7D&pdp_npi=4%40dis%21EUR%211.75%211.75%21%21%2114.34%2114.34%21%40211b61d017531729323281908e4518%2120000000198133475%21sea%21DE%216077065923%21X&curPageLogUid=1b9tTUGbt8AZ&utparam-url=scene%3Asearch%7Cquery_from%3A
https://de.aliexpress.com/item/1005006140649564.html?spm=a2g0o.productlist.main.13.405a6db7CQs9k7&algo_pvid=47a4abdb-7531-449f-88d6-09a9962e6039&algo_exp_id=47a4abdb-7531-449f-88d6-09a9962e6039-12&pdp_ext_f=%7B%22order%22%3A%22190%22%2C%22eval%22%3A%221%22%7D&pdp_npi=4%40dis%21EUR%213.19%213.19%21%21%2126.10%2126.10%21%40211b680e17531719401082190e454b%2112000035941777042%21sea%21DE%216077065923%21X&curPageLogUid=rQzkG3fA42JP&utparam-url=scene%3Asearch%7Cquery_from%3A
https://de.aliexpress.com/item/1005009534062834.html?spm=a2g0o.productlist.main.7.7d107b6eExvIs2&algo_pvid=fc84d907-ac15-49c1-a97b-e8b612e3562c&algo_exp_id=fc84d907-ac15-49c1-a97b-e8b612e3562c-6&pdp_ext_f=%7B%22order%22%3A%22-1%22%2C%22eval%22%3A%221%22%7D&pdp_npi=4%40dis%21EUR%212.80%211.99%21%21%213.20%212.28%21%40211b613917531721244292519e480d%2112000049388723576%21sea%21DE%216077065923%21X&curPageLogUid=EYqJe4fco5yF&utparam-url=scene%3Asearch%7Cquery_from%3A
https://de.aliexpress.com/item/1005006199405206.html?spm=a2g0o.productlist.main.2.26982410Fq5G3w&aem_p4p_detail=202507220126136678526563153900000164233&algo_pvid=5e44c7ca-259e-4fbc-99c5-d958a660c391&algo_exp_id=5e44c7ca-259e-4fbc-99c5-d958a660c391-1&pdp_ext_f=%7B%22order%22%3A%221447%22%2C%22eval%22%3A%221%22%7D&pdp_npi=4%40dis%21EUR%214.09%214.09%21%21%214.67%214.67%21%40210384cc17531727737981654eabe7%2112000036236556086%21sea%21DE%216077065923%21X&curPageLogUid=cni555AQYHZ6&utparam-url=scene%3Asearch%7Cquery_from%3A&search_p4p_id=202507220126136678526563153900000164233_1
https://www.amazon.de/SUNLU-Meta-PLA-Filament-1-75mm/dp/B0C24RV4PV/ref=sr_1_8?__mk_de_DE=%C3%85M%C3%85%C5%BD%C3%95%C3%91&crid=3EO0WW2XQ8G2M&dib=eyJ2IjoiMSJ9.PVpgdvaCbUAVcUUOKjlWpThMd7K6mlBlFnvJiiygZY-t917BW_W76cdgiM3t_nsXm28o0sjIb1PS1rtNrvtE0WLYM42n6GOYmdaEE5IDJWUo96ajKInOg6q1fjPCKn0WIWyHYrbt7iYhxN_OJ7xXkTN3IvJY8mySOB4K-mSjjRfuUm3e7zH4fRxchM-BriPTa6-z03RDdUspp1JgO9catLCubvRMy6cHlSiQgxatuhMlq_2wcuHkXTMXvbRIRGW1PELSlAk-P6SdBbg4LAiM35x44LqrluoYNqycROAHKRY.AyeQpBLXOM7tr_dHoTPy-ONUHgRWe3jf2m6vHbQBA9M&dib_tag=se&keywords=filament+t%C3%BCrkis&qid=1753173946&sprefix=filament+t%C3%BCrkis%2Caps%2C97&sr=8-8


that could otherwise be purchased are also included as printable versions, helping to further reduce 
costs and simplify sourcing. 

LIST OF 3D RPINTED PARTS 
NO. Part Picture Qty. .Stl File .Sat File 

HOUSING 
1. Housing 

 

1 

  
2. Housing Feet 

 

4 

  
3. Housing Tabs 

 

 

  
X-AXIS 

4. Print head 

 

1 

  
5. X-Axis Mover 

With Motor 
 

1 

  
6. X-Axis Mover 

 

1 

  
7. M6 Washer 

 

2 

  
Z-AXIS 

8. Print Bed Carrier 

 

2 

  
9. Print Bed 

 

1 

  
10. Shaft Coupler 

5mm to 8mm 
 

2 

  
SYRINGE PUMP 

11. Syringe Holder 

 

1 

  
12. Syringe Pump 

 

1 

  
13. Shaft Coupler 

5mm to 8mm 
 

1 

  
Y-AXIS 

!"#$%&'()GHI !"#$%&'()GHI

!""#$%&' !""#$%&'

!"#AB&'()GHAI-./ !"#AB&'()GHAI-./

!"#A%&DE)*HI-. !"#A%&DE)*HI-.

!"#!A%"&'E)*"HAI-"&'I'*./M1 !"#!A%"&'E)*"
HAI-"&'I'*./M1

!"#!A%"&'E)*+I-. !"#!A%&'E)*+I-./

!"#A%&'E)*H,- !"#A%&'E)*H,-

!"#ABCDE)C*+""#E"I-./ !"#ABCDE)C
*+""#E"I-./

!"#$B&DE)*+I- !"#$B&DE)*+I-

!"#A%C'EF*H,-C.LLC%ECMLL1OP4 !"#A%C'EF*H,-C
.LLC%ECMLL1OP4

!"#$%&DE)GHID#-.L0 !"#$%&DE
)GHID#-.L0

!"#$%&'E)G+)I-./ !"#AB&'()GHAI-./

!"#A%C'EF*H,-C.LLC%ECMLL1OP4 !"#A%C'EF*H,-C
.LLC%ECMLL1OP4



14. GT2 Belt 20 Tooth 
Pulley 

 

2 

  
15. GT2 Belt 32 Tooth 

Pulley 
 

1 

  
16. GT2 Belt 32 Tooth 

Pulley 
 

2 

  
      

17. M8 Washer 

 

4 

  
      

18. Shaft Locking 
Ring 

 

2 

  
OPTIONAL EXTRAS TO REDUCE COST 

19. Bushing 

 

14 

  
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

!"#$B&'"$#E$"))"G$H,''&-.L01 !"#$B&'"$#E$"))"G$
H,''&-.L01

!"#AB&'"AE#A"))"GAH,''&-A.LM''1OP4 !"#AB&'"AE#A"))"GA
H,''&-A.LM''1OP4

!"#$B&'"$#E$"))"G$H,''&-.L01 !"#$B&'"$#E$"))"G$
H,''&-.L01

!"#A%&'E)*H,- !"#A%&'E)*H,-

!"#A%C'(FGCHI-KL0NO !"#A%C'(FGC
HI-KL0NO

!"#$B&'()GHI !"#$B&'()GHI



PRINTER ASSEMBLY INSTRUCTIONS 

Tools required for the assembly: 

- Hex screwdrivers 
- Philips or flat screwdriver  
- Drill and drill bits (in case some of the holes in the housing have not come out as a perfect circle) 
- Small adjustable wrench or pliers 

Together with the written description of the assembly we have also prepared an assembly video of the 
Bioprinter. We suggest following both simultaneously to achieve the best possible result.  

 

Assembly video 

Assembly steps overview  

Housing → Z - Axis → Y - Axis → X – Axis → Syringe pump  

Assembly explanation 

Housing assembly  

- Place the four feet into their designated slots on the bottom of the housing. 
- Install the two motors on the bottom of the housing, making sure they are properly aligned and 

secured with screws. 

Z – Axis assembly  

- Slide a shaft coupler onto each end of the two threaded rods (length: 15 cm). Do not tighten the 
couplers yet. 

- Place a TR8 lead screw nut onto each threaded rod. 
- Mount a print bed carrier on top of each TR8 nut and fasten the nut to the carrier using M3 screws. 
- Position both assembled print bed carriers inside the housing. Attach the lower shaft couplers to 

the Z-axis motors located at the bottom of the housing. 
- Guide the threaded rods through their designated top holes so that each rod stands straight and 

properly aligned. 
- Tighten the shaft couplers using headless screws to secure the rods to the motor shafts. 



- Insert the four smooth rods (length: [xx] cm) through the ends of the print bed carriers to provide 
stability and linear guidance. 

- Place the print bed on top of the two carriers, align the holes, and secure the bed to the carriers 
using M6 screws and nuts. 

Y – Axis Assembly 

- Attach a stepper motor to the indent on the outside of the housing and secure it with screws. 
- Mount a 20-tooth pulley onto the motor shaft and tighten it securely 
- On the same side as the motor, insert a 25 cm smooth rod halfway through the housing. 

- Slide on three 32-tooth pulleys and the closed-loop GT2 belt, following the arrangement 
shown in the assembly video. 

- The pulley with the smaller diameter must be positioned on top of the motor housing. 
- On the opposite side of the housing, insert another 25 cm smooth rod and mount the larger 

bearings. 
- Each bearing should be sandwiched between M8 washers. 
- On both ends, secure the bearings in place with shaft lock rings, tightening them with 

headless screws. 
- Place the closed-loop GT2 belt onto the pulley next to the one mounted on top of the motor 

housing, and onto the 20-tooth pulley on the motor shaft and adjust the motor placement so that 
the closed loop belt is tight. 

X – Axis Assembly 

- Place the eight bushings onto the X-axis parts: 
- 2 bushings on each X-axis mover with motor (2 pieces) 
- 2 bushings on each X-axis mover without motor (2 pieces) 
- 4 bushings on the print head 

- Feed two 20 cm smooth rods through the bushings on the print head. 
- Attach the X-axis movers on each side of the smooth rods. 
- Mount the motor onto the “X-axis mover with motor” and secure it with screws. 

- Install a 20-tooth pulley onto the motor shaft and secure it with a headless screw. 
- On the “X-axis mover without motor,” insert an M6 screw through the bottom. 

- Slide a small bearing onto the screw, sandwiched between two M6 washers. 
- Secure the assembly in place with an M6 nut. 

- Position the X-axis assembly inside the frame with the X-axis mover facing away from the motor in 
the outside of the housing. 

- Insert two 25 cm smooth rods through both X-axis movers, ensuring proper alignment (see 
assembly video for orientation). 

- Cut the open-loop GT2 belts to the required length. 
- Attach and tension the belts as shown in the video. 
- The belts are joined and tightened on the toothed sections of the X-axis movers and the 

print head. 

Syringe pump assembly  

- Attach two bushings onto the syringe pump body. 
- Place a TR8 nut between the bushings and secure it with M3 screws. 
- Mount a shaft coupler onto the motor shaft. 



- Insert the 10 cm threaded rod into the coupler and secure it in place with the headless screws. 
- Feed the threaded rod halfway into the syringe holder. 
- Slide the syringe pump assembly onto the threaded rod as shown in the assembly video. 
- Mount the motor in place using long M3 screws. 
- Attach the complete syringe pump assembly to the housing using two M6 screws and secure 

them with nuts. 
- (Optional) For improved stability and guidance, install two 10 cm smooth rods alongside the 

assembly. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



ELECTRONICS 
Tools required for the assembly 

- Dupont wires with 4-pin female housing 
- Wire crimper 
- Digital multimeter (voltmeter/continuity tester) 
- Wire stripper 
- Small ceramic or plastic screwdriver (for trim pot adjustment) 

Assembly explanation 

Mount Ramps 1.6 to Audrino Mega 2560. 

- Make sure the pins of the 2 boards line up and that they are fully in place. 

Insert 3 jumper cables under each axis used (X, Y, Z, E0). 

- The 3 jumper cables enable: 
- Smooth movement. 
- Correct distance moved to distance specified.  

Insert all 4 drivers in the Ramps board. 

- Make sure that the pins are lined up and the drivers are fully set. 
- Install the heat sinks provided with the drivers and the Ramps. 

Finding the motors coils  

- Each stepper motor has 4 wires with diOerent colours which correspond to the 2 coils of the 
motor A and B  

- The coils are: A+, A-, B+, B-  
- There are 2 ways to find the coils for the stepper motors  

- Finding the specifications online: 
- Most manufacturers provide data for the stepper motors coils according to the 

colour of the wires used. 
- Use a multimeter: 

- Use the multimeter in continuity mode (or lowest resistance setting). 
- Touch two wires at a time. If the meter beeps or shows ~2–5 Ω, those two wires are 

one coil. The other two wires form the second coil. 
- Label them as A+ / A– and B+ / B–. 

Connecting the motors to the Ramps board 

- Each motor port on each axis in the Ramps board is labelled as: 
- 1B – 1A – 2A – 2B 

- The correct connection of the Ramps to the motor wires is like this: 
- 1B – A+  /  1A – A-  /  2A – B+  /  2B – B- 

- Use Dupont connectors to make it easier. 
- Connect the axis accordingly. 

- X – axis to X – axis  
- Y – axis to Y – axis  
- Z – axis to Z – axis ( the Z – axis has 2 rows of pins so we don’t need to splice the wires of the 

Z- axis motors)   



- Syringe pump – E0  

Connect the power supply to the Ramps power terminal  

- Wires are connected in this way: 
- +V from the power supply to + in the Ramps power terminal. 
- - V from the power supply to  - in the Ramps power terminal. 

- Screw the screws securely. 
- Do not power on the board. 

Set driver current (Vref) 

- Measuring Vref 
- Plug the Audrino into the computer  
- Turn on the 24 V power supply. 
- Place the black probe of the multimeter on a RAMPS ground pin. 
- Place the red probe on the screw of the driver’s trim potentiometer. 
- Read the voltage on the multimeter. 

- Adjusting Vref 
- Use a ceramic/plastic screwdriver to turn the trim pot. 
- Clockwise → lowers Vref 
- Counterclockwise → raises Vref 
- Adjust in very small increments and recheck after each turn. 

- Recommended Vref Values 
- X, Y, and Extruder motors (single NEMA 11) → 0.35 V 
- Z-axis (two NEMA 11 motors on one driver) → 0.70 V 

- Adjust based on the needs of your motors 

Recommended and safest power up and o= sequence  
- Connect the Arduino Mega to the PC with a USB cable. This powers the logic side at 5 V and allows 

software communication. 
- Once recognized by the PC, switch ON the 24 V power supply to power the motors. 
- When shutting down, turn OFF the 24 V power supply first, then disconnect USB. 

Double check all the wiring and components and if all is okay we can move on to the software.  



SOFTWARE 
The final part of the setup is the software. To get the printer fully operational, 5 main software 
components are required: 

- Arduino IDE: used to upload the Marlin firmware to the Audrino Mega. 
- Marlin (Frimware): runs on the Audrino and controls motors, extruders and print functions. 
- Pronterface (Control Software): connects the printer to a computer for test calibration and 

sending G-code commands.  
- Cura (Slicer): converts 3D models into G-code that the printer can use. 
- Python G-code converter. 

Together they provide the firmware, control, and file preparation needed to run the bioprinter. 

Installing and connecting Arduino IDE 

- Download 

- Go to the oOicial Arduino website: https://www.arduino.cc/en/software/  

- Download the installer for your operating system (Windows, macOS, or Linux). 

- Go through all the on-screen installation steps. 

- Connect the Board 

- Plug the Arduino Mega 2560 into your computer with a USB cable. 

- Open Arduino IDE and go to Tools → Board → Arduino Mega 2560. 

- Select the correct Port under Tools → Port (it usually shows as “Arduino Mega”). 

- Verify Installation 

- Open File → Examples → Basics → Blink. 

- Click Upload. 

- If the onboard LED starts blinking, the IDE is installed correctly and communicating with the 
board. 

Uploading Marlin to Arduino Mega 2560  

- We have configured a Marlin file which can be uploaded directly to Arduino. 
- To upload the provided Marlin configuration, follow these steps: 

- Open Arduino IDE and connect your board  
- Click File → Open → Marlin-2.1.2.5 → Marlin → Marlin.ino 
- Once Marlin.ino is opened you should see 4 tabs in Arduino IDE 

- Marlin.ino 
- Configuration.h  
- Configuration_adv.hw 
- Version.h  

- On the top left click the arrow button that says upload to start uploading. 
- Once it is uploaded we are ready for Pronterface. 

https://www.arduino.cc/en/software/


Downloading and connecting to Pronterface 

- Download 
- Go to the oOicial Printrun GitHub page: https://github.com/kliment/Printrun 
- Download the latest release for your operating system (Windows, macOS, or Linux). 
- Extract the folder after downloading. 
- Run Pronterface.exe 

- Connect to the Printer 
- Plug the Arduino Mega (with RAMPS) into your computer using a USB cable. 
- Open Pronterface. 
- In the top left, select the correct COM port (on Windows) or ttyUSB/ttyACM device (on 

Linux/macOS). 
- Set the baud rate to 115200. 
- Click Connect. 
- If the connection is successful, Pronterface will display printer status messages in the 

console window. 
- First Test 

- Use the on-screen buttons to jog the X, Y, and Z axes slowly. 
- Confirm that each axis moves in the expected direction. 
- If any axis moves the wrong way, direction can be corrected later in the Marlin firmware. 

**(The Z – axis on our bio printer is also the print bed so in order to increase a layer Z – axis must go down.                                                                                                    
T    To do that we have flipped the direction of the Z – axis with Z+ going down and Z- going up.)  
 
Downloading and configuring Cura  

- Download 
- Go to the oOicial website: https://ultimaker.com/software/ultimaker-cura  
- Download the installer for your operating system (Windows, macOS, or Linux). 

- Install 
- Run the installer and follow the setup instructions. 
- After installation, open Cura. 

- Add the Printer 
- In Cura, go to Settings → Printer → Add Printer. 
- Choose Custom FFF Printer. 
- Give it a name (e.g. bbw Bioprinter). 

- One the machine setting page configure these settings: 
- Size of the build platform as a rectangular 150 mm x 150 mm x 150 mm. 
- The origin at center checkbox should be checked and all heated options 

unchecked since the Printess does not have any heating accessories. 
- Under G-code flavor select “Marlin”. 
- The current setting of the print head is min X: -150, max X: 150, min Y: -150, max 

Y:150, and the number of extruders is 1. 
- Apply Extruder oOsets should be unchecked. 
- Delete everything in the Start G-code and End G-Code section. These sections are 

where the users would write their own start and end g-code to be applied to Cura’s g-
code output. 

- Under extruder tab 

https://github.com/kliment/Printrun
https://ultimaker.com/software/ultimaker-cura


- Enter the desired needle diameter used in the Nozzle size field. 
- Enter the inner diameter of the syringe into the Compatible material diameter. 
- Enter 0 for the remaining settings. 

- Save the configuration 
- Modifying Print Settings (Fully customisable but we recommend changing this setting) 

- Limit the speeds to 5mm/s 
- Disable print cooling  
- Save your print setting profile  

- Upload your 3D model and slice it. 

 G-code converter Python program 

- In order to get the correct extrusion rates as we are not working with filament we need to 
modify the Cura G-code with the provided python program. 

- Convert the provided .txt file to .py to start using  
- Prepare your Cura file 

- Slice your 3D model in Cura as usual. 
- Save the output as gcode.txt. 
- At the top of this file, add three parameter lines in order for the script to calculate 

extrusion rates based on this formula: 
- k=1.0 
- bd=4.6 
- nd=0.8 
- k = scaling factor 
- bd = barrel (syringe) diameter in mm 
- nd = needle diameter in mm 

- Run the script 
- Place gcode.txt in the same folder as the Python script. 
- Open a terminal in that folder and run bioprint_post.py 
- The script will create a new file called gcode_bio.gcode. 

- Print 
- Open Pronterface. 
- Connect to the printer. 
- Move the printer so that the needle barely touches the print bed  
- Load gcode_bio.gcode and start the print 

 

   

 

 

 

 

 



TROUBLESHOOTING 

Pronterface File Errors 

- Files must be .txt or .gcode — .rtf files will not work. 
- If Pronterface doesn’t run, disconnect and reconnect the USB. 

Material Does Not Stick to Substrate 

- The syringe is likely too high. Manually lower it until it just touches the surface, then raise it about 
0.2 mm. 

Motors Make Noise but Do Not Move 

- Motion speed is too high — add an F command (e.g., F300) to limit feedrate. 
- Check for dry bearings — apply light lubrication if movement stalls. 
- If the problem persists, adjust driver current (Vref). 

Axes Crash or Move Incorrectly 

- Ensure the G-code uses correct positioning (G90 absolute + G92 zero before starting). 
- Loose motor wiring can also cause missed movement. 

 


